import Foundation
let pattern = #"^[-+]?([1-9]*[0-9]?\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)