# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[-+]?([1-9]*[0-9]?\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$"
test_str = ("0.000000\n"
"-0.00000\n"
"+0.0000\n"
".1\n"
"+.1\n"
"-.1\n"
"+00000.1\n"
"-00000.1\n"
"000000000000000.1\n"
"000.1111\n"
"00.11\n"
"0.1\n"
"-0.1\n"
"+0.1\n"
"1.1\n"
"+1.1\n"
"-1.1\n"
"10.11\n"
"+10.11\n"
"+10.11\n"
"100.11\n"
"+100.11\n"
"-100.11\n"
"1000.111\n"
"+1000.111\n"
"-1000.111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.