re = /^allowed.*Count$/m
str = 'allowedHardwareCount
allowedIpAddressCount
allowedReplicationHardwareCount
allowedReplicationIpAddressCount
allowedReplicationSubnetCount
allowedReplicationVirtualGuestCount
allowedSubnetCount
allowedVirtualGuestCount'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end