package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^allowed.*Count$`)
var str = `allowedHardwareCount
allowedIpAddressCount
allowedReplicationHardwareCount
allowedReplicationIpAddressCount
allowedReplicationSubnetCount
allowedReplicationVirtualGuestCount
allowedSubnetCount
allowedVirtualGuestCount`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}