re = /\d+px/
str = '{"background":"linear-gradient(225deg,rgba(255, 255, 255, 0.36) 0%,rgba(255, 255, 255, 0.8) 100%)","boxShadow":"0 12px 12px -3px rgba(0, 0, 0, 0.08),0 -8px 14px 0 rgba(255, 255, 255, 0.76),inset 0 0 1px 0 rgba(255, 255, 255, 1),inset 0 2px 0 0 rgba(255, 255, 255, 1)"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end