using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+px";
string input = @"{""background"":""linear-gradient(225deg,rgba(255, 255, 255, 0.36) 0%,rgba(255, 255, 255, 0.8) 100%)"",""boxShadow"":""0 12px 12px -3px rgba(0, 0, 0, 0.08),0 -8px 14px 0 rgba(255, 255, 255, 0.76),inset 0 0 1px 0 rgba(255, 255, 255, 1),inset 0 2px 0 0 rgba(255, 255, 255, 1)""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}