re = /data-(\S+)=\"((?:\\.|[^"\\])*)"/m
str = '<div data-one="true" id="a" data-two="Aaaaa" data-three="01234567" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end