using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"data-(\S+)=\""((?:\\.|[^""\\])*)""";
string input = @"<div data-one=""true"" id=""a"" data-two=""Aaaaa"" data-three=""01234567"" />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}