re = /((\d{3}-)?\d{3}-\d{4}(,)?){3}/m
str = 'My numbers are 415-555-1234,555-4242,212-555-0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end