$re = '/((\d{3}-)?\d{3}-\d{4}(,)?){3}/m';
$str = 'My numbers are 415-555-1234,555-4242,212-555-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);