# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z][a-z]*(([A-Z][a-z]+)*[A-Z]?|([a-z]+[A-Z])*|[A-Z])$"
test_str = ("affine3D\n"
"lThan30DaysCount\n"
"lessThan30DaysCount\n"
"lessThan30DaysCountA\n"
"greaterThan30LessThan60DaysCount\n"
"greaterThan60LessThan90DaysCount\n"
"greaterThan90DaysCount\n"
"snake_case\n"
"PascalCase\n"
"2PascalCase\n"
"streamIOIO\n"
"gREATERDtha\n"
"modeADFAFdsADFads\n"
"aBabcABCDabcABC\n"
"modeADFdsADFads\n"
"streamIO\n"
"aBCabcABCabcA\n"
"aBCabcA\n"
"aabc123\n"
"aabcABC\n"
"deviceSNS\n"
"pathASNs\n"
"dscpCP\n"
"awsVPC\n"
"deviceID\n"
"gREA1\n"
"gREAt\n"
"gREAtREAt\n"
"cP3\n"
"a1\n"
"aABC\n"
"a123\n"
"modeADFsADFads\n"
"a1G\n"
"modeADFads\n"
"supportsIpv6OnIos\n"
"pascal2Case\n"
"pascal2CaseA\n"
"mode2A\n"
"mode2A2\n"
"mode2A2A\n"
"createAMode\n"
"createBMode\n"
"hTMLParser\n"
"hELLO\n"
"camel01C\n"
"camel01c01\n"
"camel01C01\n"
"camel01CC01\n"
"camel0a1c1\n"
"camel0a1C1\n"
"camel0ac1b1C1\n"
"camelC1\n"
"camelCA\n"
"camelCa1\n"
"camelCa_1\n"
"ibsReleaseTestVerificationRegressioNSuite\n"
"modeA\n"
"pascalCaseA\n"
"pascalCase\n"
"madeEasy\n"
"wonderFul\n"
"andMe\n"
"context\n"
"htmlParser\n"
"h\n"
"aaA\n"
"a\n"
"ab\n"
"abc\n"
"abcd\n"
"abcde\n"
"camelCasE\n"
"aGa\n"
"camelCasecamelCasecamelCasecamelCasecamelCasecamelCase\n"
"aG\n"
"alphabet\n"
"camelCase\n"
"xmlHttpRequest\n"
"newCustomerId\n"
"innerStopwatch\n"
"youTubeImporter\n"
"youtubeImporter\n"
"camelC\n"
"ibsReleaseTestVerificationRegressionSuite\n"
"ibsReleaseTestVerificationRegressioN")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.