#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z][a-z]*(([A-Z][a-z]+)*[A-Z]?|([a-z]+[A-Z])*|[A-Z])$"
Local $sString = "affine3D" & @CRLF & _
"lThan30DaysCount" & @CRLF & _
"lessThan30DaysCount" & @CRLF & _
"lessThan30DaysCountA" & @CRLF & _
"greaterThan30LessThan60DaysCount" & @CRLF & _
"greaterThan60LessThan90DaysCount" & @CRLF & _
"greaterThan90DaysCount" & @CRLF & _
"snake_case" & @CRLF & _
"PascalCase" & @CRLF & _
"2PascalCase" & @CRLF & _
"streamIOIO" & @CRLF & _
"gREATERDtha" & @CRLF & _
"modeADFAFdsADFads" & @CRLF & _
"aBabcABCDabcABC" & @CRLF & _
"modeADFdsADFads" & @CRLF & _
"streamIO" & @CRLF & _
"aBCabcABCabcA" & @CRLF & _
"aBCabcA" & @CRLF & _
"aabc123" & @CRLF & _
"aabcABC" & @CRLF & _
"deviceSNS" & @CRLF & _
"pathASNs" & @CRLF & _
"dscpCP" & @CRLF & _
"awsVPC" & @CRLF & _
"deviceID" & @CRLF & _
"gREA1" & @CRLF & _
"gREAt" & @CRLF & _
"gREAtREAt" & @CRLF & _
"cP3" & @CRLF & _
"a1" & @CRLF & _
"aABC" & @CRLF & _
"a123" & @CRLF & _
"modeADFsADFads" & @CRLF & _
"a1G" & @CRLF & _
"modeADFads" & @CRLF & _
"supportsIpv6OnIos" & @CRLF & _
"pascal2Case" & @CRLF & _
"pascal2CaseA" & @CRLF & _
"mode2A" & @CRLF & _
"mode2A2" & @CRLF & _
"mode2A2A" & @CRLF & _
"createAMode" & @CRLF & _
"createBMode" & @CRLF & _
"hTMLParser" & @CRLF & _
"hELLO" & @CRLF & _
"camel01C" & @CRLF & _
"camel01c01" & @CRLF & _
"camel01C01" & @CRLF & _
"camel01CC01" & @CRLF & _
"camel0a1c1" & @CRLF & _
"camel0a1C1" & @CRLF & _
"camel0ac1b1C1" & @CRLF & _
"camelC1" & @CRLF & _
"camelCA" & @CRLF & _
"camelCa1" & @CRLF & _
"camelCa_1" & @CRLF & _
"ibsReleaseTestVerificationRegressioNSuite" & @CRLF & _
"modeA" & @CRLF & _
"pascalCaseA" & @CRLF & _
"pascalCase" & @CRLF & _
"madeEasy" & @CRLF & _
"wonderFul" & @CRLF & _
"andMe" & @CRLF & _
"context" & @CRLF & _
"htmlParser" & @CRLF & _
"h" & @CRLF & _
"aaA" & @CRLF & _
"a" & @CRLF & _
"ab" & @CRLF & _
"abc" & @CRLF & _
"abcd" & @CRLF & _
"abcde" & @CRLF & _
"camelCasE" & @CRLF & _
"aGa" & @CRLF & _
"camelCasecamelCasecamelCasecamelCasecamelCasecamelCase" & @CRLF & _
"aG" & @CRLF & _
"alphabet" & @CRLF & _
"camelCase" & @CRLF & _
"xmlHttpRequest" & @CRLF & _
"newCustomerId" & @CRLF & _
"innerStopwatch" & @CRLF & _
"youTubeImporter" & @CRLF & _
"youtubeImporter" & @CRLF & _
"camelC" & @CRLF & _
"ibsReleaseTestVerificationRegressionSuite" & @CRLF & _
"ibsReleaseTestVerificationRegressioN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")