import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https|ftp|ftps):\\/\\/)?(?<url_host>(\\[[^\\]]+\\]|[^\\/:\\n]+))(?<url_port>(:\\d+)?)(\\/)?";
final String string = "sony.com\n"
+ "http://cnn.com/story\n"
+ "https://google.com:444/stuff\n"
+ "1.2.3.4:12/ok\n"
+ "1.2.3.4/ok\n"
+ "2.2.2.2:443\n"
+ "/dontmatchme\n"
+ "ftp://mononym/path\n"
+ "http://google.com\n"
+ "www.test\n"
+ "http://[2001:1890:1c00:6500::d:7]/rar/\n"
+ "[2001:1890:1c00:6500::d:7]\n"
+ "[2001:1890:1c00:6500::d:7]/test\n"
+ "http://[2001:1890:1c00:6500::d:7]:8080/rar/\n"
+ "[2001:1890:1c00:6500::d:7]:8080\n"
+ "[2001:1890:1c00:6500::d:7]:4/test\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}