#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((http|https|ftp|ftps):\/\/)?(?<url_host>(\[[^\]]+\]|[^\/:\n]+))(?<url_port>(:\d+)?)(\/)?"
Local $sString = "sony.com" & @CRLF & _
"http://cnn.com/story" & @CRLF & _
"https://google.com:444/stuff" & @CRLF & _
"1.2.3.4:12/ok" & @CRLF & _
"1.2.3.4/ok" & @CRLF & _
"2.2.2.2:443" & @CRLF & _
"/dontmatchme" & @CRLF & _
"ftp://mononym/path" & @CRLF & _
"http://google.com" & @CRLF & _
"www.test" & @CRLF & _
"http://[2001:1890:1c00:6500::d:7]/rar/" & @CRLF & _
"[2001:1890:1c00:6500::d:7]" & @CRLF & _
"[2001:1890:1c00:6500::d:7]/test" & @CRLF & _
"http://[2001:1890:1c00:6500::d:7]:8080/rar/" & @CRLF & _
"[2001:1890:1c00:6500::d:7]:8080" & @CRLF & _
"[2001:1890:1c00:6500::d:7]:4/test" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")