re = /(?P<user>^[a-zA-Z]+[\w+.-]*\@)(?P<domain>[\w+.-]*[a-zA-Z]$)/
str = 's@gmail.com '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end