package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<user>^[a-zA-Z]+[\w+.-]*\@)(?P<domain>[\w+.-]*[a-zA-Z]$)`)
var str = `s@gmail.com `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}