// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\p{N}").unwrap();
let string = "🌍💰🕧👨👩👧🤔🈂️ 😘 ☃♨️🗺️📄🐥⚒️🌀🦁🈷️🈵🆚🀄⭐️❤️➡️➰️⤴️➿️⭕️㊙️🀄🃏🅱️🆎〰️⤵️⬜️〽️⭐️🆒⏩️©️Ⓜ️☪️☕️⏺️▶️®️™️⏳️ ,er 34 4(0 😊
Пи Ши ⓽⓽⓺⓵⓼⓷⓺⓹⓶⓷ ⁸⁹⁸¹ ⁷⁴¹ ⁴⁵ ⁵³1️⃣
Привет! .Хочешь... ра3влечься... Пи Ши ..ⓌⓗОⓣⓈАⓅ... ⓽⓺⓹⓺⓶⑦④⓺⑦⓪
ÓČTǞᗷѢ ČᗷΌҊ ℋΌḾĚҎ ℋǞगӤᗯᎩ ÇǞḾǞ
Орëл
Привет, д🅔🅑🅞ч🅚и на 🅑ы🅔зд по РФ 🔞💦♥️||🅑🅐т🅒🅐п ➐ ➒➒➏ ➒⓿➎ ➎➍ ⓿➑ 🄆 Ted efsavsaredee
❤️❤️❤️❤️❤️❤️🇸🇮🇸🇮🇸🇮💋💋💋💋💋💋🔥🔥🔥🔥🔥🇬🇪💫🥳😉🇳🇮✍️ ⒛ 𝟑 𝟛 𝟥 Ʒ 🄄 ⒊
79627241085";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}