const regex = new RegExp('\\p{N}', 'g')
const str = `🌍💰🕧👨👩👧🤔🈂️ 😘 ☃♨️🗺️📄🐥⚒️🌀🦁🈷️🈵🆚🀄⭐️❤️➡️➰️⤴️➿️⭕️㊙️🀄🃏🅱️🆎〰️⤵️⬜️〽️⭐️🆒⏩️©️Ⓜ️☪️☕️⏺️▶️®️™️⏳️ ,er 34 4(0 😊
Пи Ши ⓽⓽⓺⓵⓼⓷⓺⓹⓶⓷ ⁸⁹⁸¹ ⁷⁴¹ ⁴⁵ ⁵³1️⃣
Привет! .Хочешь... ра3влечься... Пи Ши ..ⓌⓗОⓣⓈАⓅ... ⓽⓺⓹⓺⓶⑦④⓺⑦⓪
ÓČTǞᗷѢ ČᗷΌҊ ℋΌḾĚҎ ℋǞगӤᗯᎩ ÇǞḾǞ
Орëл
Привет, д🅔🅑🅞ч🅚и на 🅑ы🅔зд по РФ 🔞💦♥️||🅑🅐т🅒🅐п ➐ ➒➒➏ ➒⓿➎ ➎➍ ⓿➑ 🄆 Ted efsavsaredee
❤️❤️❤️❤️❤️❤️🇸🇮🇸🇮🇸🇮💋💋💋💋💋💋🔥🔥🔥🔥🔥🇬🇪💫🥳😉🇳🇮✍️ ⒛ 𝟑 𝟛 𝟥 Ʒ 🄄 ⒊
79627241085`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}