const regex = /(?:(?'Key'[^\n][\w|\s]*)=(?'Value'[^;'"",`\n]+);?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?\'Key\'[^\\n][\\w|\\s]*)=(?\'Value\'[^;\'"",`\\n]+);?)', 'gm')
const str = `AccountEndpoint=https://some-base-name.documents.azure.com:443/;AccountKey=kascuh9823nfsdvxc==;
Endpoint=sb://other-more-different-name.servicebus.windows.net/;SharedAccessKeyName=mysak-name;SharedAccessKey=msd8fs2bsc==;EntityPath=someentitypath;TransportType=Amqp
Data Source=myServerName.whatever.local;Initial Catalog=MyDatabaseName;Persist Security Info=True;User ID=myUserId;Password=MyBadPractice;MultipleActiveResultSets=True;MultiSubnetFailover=True;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}