import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?'Key'[^\\n][\\w|\\s]*)=(?'Value'[^;'\"\",`\\n]+);?)";
final String string = "AccountEndpoint=https://some-base-name.documents.azure.com:443/;AccountKey=kascuh9823nfsdvxc==;\n"
+ "Endpoint=sb://other-more-different-name.servicebus.windows.net/;SharedAccessKeyName=mysak-name;SharedAccessKey=msd8fs2bsc==;EntityPath=someentitypath;TransportType=Amqp\n"
+ "Data Source=myServerName.whatever.local;Initial Catalog=MyDatabaseName;Persist Security Info=True;User ID=myUserId;Password=MyBadPractice;MultipleActiveResultSets=True;MultiSubnetFailover=True;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}