$re = '/^[6789][0-9]{9}$/m';
$str = '7906575967
6214569878
9761222236
8865984201w
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);