package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[6789][0-9]{9}$`)
var str = `7906575967
6214569878
9761222236
8865984201w
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}