re = /^(<<(?>[^<>\n]+|(?1))>>)$/m
str = '<<totAmt>>
<<accNum>>
<<agentName>>
<<payLink>>
<<cName>
<<agentName>>>>>>>>
<cName>
<<<<<payLink>>
<<cName<<>>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end