#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(<<(?>[^<>\n]+|(?1))>>)$"
Local $sString = "<<totAmt>>" & @CRLF & _
"<<accNum>>" & @CRLF & _
"<<agentName>>" & @CRLF & _
"<<payLink>>" & @CRLF & _
"" & @CRLF & _
"<<cName>" & @CRLF & _
"<<agentName>>>>>>>>" & @CRLF & _
"<cName>" & @CRLF & _
"<<<<<payLink>>" & @CRLF & _
"<<cName<<>>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")