use strict;
my $str = '1/1/2019
2/29/2020
1/31/00
2/29/2000
3/31/2019
2/29/2020
7/23/1999
7/31/1999
7/28/1999
7/21/1999
7/5/1964
7/21/2000
2/29/1900
6/5/1999
5/5/1999
4/4/1999
3/3/1999
2/2/1999
2/29/1996
2/29/2000
1/1/1954
1/1/1985
3/31/2019
1/29/2010
10/21/1967';
my $regex = qr/^(?:(?:(?:0?[13578]|1[02])(\/)31)\1|(?:(?:0?[1,3-9]|1[0-2])(\/)(?:29|30)\2))(?:(?:19|[2-9]\d)\d{2})$|^(?:0?2(\/)29\3(?:(?:(?:19|20)(?:0[048]|[2468][048]|[13579][26]))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\/)(?:0?[1-9]|1\d|2[0-8])\4(?:(?:19|[0-9]\d)?\d{2})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}