const regex = /^(?:(?:(?:0?[13578]|1[02])(\/)31)\1|(?:(?:0?[1,3-9]|1[0-2])(\/)(?:29|30)\2))(?:(?:19|[2-9]\d)\d{2})$|^(?:0?2(\/)29\3(?:(?:(?:19|20)(?:0[048]|[2468][048]|[13579][26]))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\/)(?:0?[1-9]|1\d|2[0-8])\4(?:(?:19|[0-9]\d)?\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:0?[13578]|1[02])(\\\/)31)\\1|(?:(?:0?[1,3-9]|1[0-2])(\\\/)(?:29|30)\\2))(?:(?:19|[2-9]\\d)\\d{2})$|^(?:0?2(\\\/)29\\3(?:(?:(?:19|20)(?:0[048]|[2468][048]|[13579][26]))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\\\/)(?:0?[1-9]|1\\d|2[0-8])\\4(?:(?:19|[0-9]\\d)?\\d{2})$', 'gm')
const str = `1/1/2019
2/29/2020
1/31/00
2/29/2000
3/31/2019
2/29/2020
7/23/1999
7/31/1999
7/28/1999
7/21/1999
7/5/1964
7/21/2000
2/29/1900
6/5/1999
5/5/1999
4/4/1999
3/3/1999
2/2/1999
2/29/1996
2/29/2000
1/1/1954
1/1/1985
3/31/2019
1/29/2010
10/21/1967`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}