import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www.)?((player.vimeo.com\\/video\\/[0-9]{9})|((youtube.com|youtu\\.be)\\/embed\\/([\\w-]{9,11})))";
final String string = "http://www.youtube.com/watch?v=GKnQGP67Xd0\n"
+ "https://www.youtube.com/watch?v=GKnQGP67Xd0\n"
+ "https://www.youtube.com/watch?v=GKnQGP67Xd0\n"
+ "https://www.youtube.com/watch?v=GKnQGP67Xd0\n"
+ "https://vimeo.com/662065137\n"
+ "https://vimeo.com/662065137\n"
+ "https://www.youtube.com/c/riotgamesmusic\n"
+ "https://vimeo.com/662065137\n"
+ "https://youtu.be/aXUCHNaZkWo\n"
+ "https://vimeo.com/662065137\n"
+ "https://vimeo.com/baconbaconbacon\n"
+ "https://www.youtube.com/channel/UCG_wKjFPEpdHf1Q6bTdE2JA\n"
+ "https://player.vimeo.com/video/662065137\n\n"
+ "última formato corto: http://youtu.be/NLqAF9hrVbY\n"
+ "iframe: http://www.youtube.com/embed/NLqAF9hrVbY\n"
+ "iframe (seguro): https://www.youtube.com/embed/NLqAF9hrVbY\n"
+ "objeto param: http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US\n"
+ "objeto de incrustación: http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US\n"
+ "ver: http://www.youtube.com/watch?v=NLqAF9hrVbY\n"
+ "usuarios: http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo\n"
+ "ytscreeningroom: http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I\n"
+ "cualquier cosa vale!: http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/2/PPS-8DMrAn4\n"
+ "cualquier/subdominio/: http://gdata.youtube.com/feeds/api/videos/NLqAF9hrVbY\n"
+ "más params: http://www.youtube.com/watch?v=spDj54kf-vY&feature=g-vrec\n"
+ "la consulta puede tener el punto: http://www.youtube.com/watch?v=spDj54kf-vY&feature=youtu.be";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}