#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https?:\/\/)?(www.)?((player.vimeo.com\/video\/[0-9]{9})|((youtube.com|youtu\.be)\/embed\/([\w-]{9,11})))"
Local $sString = "http://www.youtube.com/watch?v=GKnQGP67Xd0" & @CRLF & _
"https://www.youtube.com/watch?v=GKnQGP67Xd0" & @CRLF & _
"https://www.youtube.com/watch?v=GKnQGP67Xd0" & @CRLF & _
"https://www.youtube.com/watch?v=GKnQGP67Xd0" & @CRLF & _
"https://vimeo.com/662065137" & @CRLF & _
"https://vimeo.com/662065137" & @CRLF & _
"https://www.youtube.com/c/riotgamesmusic" & @CRLF & _
"https://vimeo.com/662065137" & @CRLF & _
"https://youtu.be/aXUCHNaZkWo" & @CRLF & _
"https://vimeo.com/662065137" & @CRLF & _
"https://vimeo.com/baconbaconbacon" & @CRLF & _
"https://www.youtube.com/channel/UCG_wKjFPEpdHf1Q6bTdE2JA" & @CRLF & _
"https://player.vimeo.com/video/662065137" & @CRLF & _
"" & @CRLF & _
"última formato corto: http://youtu.be/NLqAF9hrVbY" & @CRLF & _
"iframe: http://www.youtube.com/embed/NLqAF9hrVbY" & @CRLF & _
"iframe (seguro): https://www.youtube.com/embed/NLqAF9hrVbY" & @CRLF & _
"objeto param: http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US" & @CRLF & _
"objeto de incrustación: http://www.youtube.com/v/NLqAF9hrVbY?fs=1&hl=en_US" & @CRLF & _
"ver: http://www.youtube.com/watch?v=NLqAF9hrVbY" & @CRLF & _
"usuarios: http://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo" & @CRLF & _
"ytscreeningroom: http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I" & @CRLF & _
"cualquier cosa vale!: http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/2/PPS-8DMrAn4" & @CRLF & _
"cualquier/subdominio/: http://gdata.youtube.com/feeds/api/videos/NLqAF9hrVbY" & @CRLF & _
"más params: http://www.youtube.com/watch?v=spDj54kf-vY&feature=g-vrec" & @CRLF & _
"la consulta puede tener el punto: http://www.youtube.com/watch?v=spDj54kf-vY&feature=youtu.be"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")