$re = '/((0?[x|X])|#)?[0-9,A-F,a-f]{8}|#([0-9,A-F,a-f]{6})/m';
$str = 'werwerwer 0x00000258qqdwef 4123r31ed0x0xxx00x0x00000001wefv sdfgsdgfdsfghsdfg#FA1EBFfwefweberF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);