package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((0?[x|X])|#)?[0-9,A-F,a-f]{8}|#([0-9,A-F,a-f]{6})`)
var str = `werwerwer 0x00000258qqdwef 4123r31ed0x0xxx00x0x00000001wefv sdfgsdgfdsfghsdfg#FA1EBFfwefweberF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}