$re = '/\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\\\]*(?:\\\\.[^"\\\\]*)*"|(\')[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*\')/m';
$str = 'a="abc";
b=\'def\';
c="That\'s the way to do it";
d=\'That\\\'s the way "to do it"\';
e=e.replace(//g, \'"\');
f=f.replace(/\'/g, \'"\');
g=g.replace(/\\\'/g, \'"\');
h=h.replace(/\\"/g, \'\\"\');
i=i.replace(/\\\\"/g, \'\\\\"\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);