use strict;
my $str = 'a="abc";
b=\'def\';
c="That\'s the way to do it";
d=\'That\\\'s the way "to do it"\';
e=e.replace(//g, \'"\');
f=f.replace(/\'/g, \'"\');
g=g.replace(/\\\'/g, \'"\');
h=h.replace(/\\"/g, \'\\"\');
i=i.replace(/\\\\"/g, \'\\\\"\');';
my $regex = qr/\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|(")[^"\\]*(?:\\.[^"\\]*)*"|(')[^'\\]*(?:\\.[^'\\]*)*')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}