import Foundation
let pattern = #"^.*((2020Model|Engine|TIMFCST).*\.dba|.*\.dta)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\2020db.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ccaldb.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\cinput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\cinput2.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\coutput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\coutput2.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ecaldb.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egcaldb.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\eginput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput2.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput3.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\einput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\eoutput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ercaldb.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Engine\erinput.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\testing.dta
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Informetrica\informet.dba
Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Informetrica\TIMFCST\F2201_EC\informet.dba
Deleted file - c:\Archives\23.01.13_2020ESDC\Informetrica\informet.dba
Deleted file - c:\Archives\23.01.13_2020ESDC\Informetrica\TIMFCST\F2201_EC\informet.dba
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)