import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*((2020Model|Engine|TIMFCST).*\\.dba|.*\\.dta)";
final String string = "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\2020db.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ccaldb.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput2.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput2.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ecaldb.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egcaldb.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eginput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput2.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput3.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\einput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eoutput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ercaldb.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Engine\\erinput.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\testing.dta\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\informet.dba\n"
+ "Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba\n"
+ "Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\informet.dba\n"
+ "Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}