use strict;
my $str = 'src/profile/Admin.profile
src/profile/Chatter External User.profile
src/profile/Chatter Free User.profile
src/profile/Chatter Moderator User.profile
src/profile/Company Communities User.profile
src/profile/ContractManager.profile
src/profile/Guest License User.profile
src/profile/High Volume Customer Portal User.profile
src/profile/Integratie.profile
src/profile/MarketingProfile.profile
src/profile/OWS.profile
src/profile/Photos Profile.profile
src/profile/PostNL - Audit.profile
src/profile/PostNL - Business gebruiker.profile
src/profile/PostNL - Controlroom C%26S Aanmaker - CC.profile
src/profile/PostNL - Controlroom C%26S Analist - CC.profile
src/profile/PostNL - Controlroom C%26S Behandelaar - CC.profile
src/profile/PostNL - DUB - CC.profile
src/profile/PostNL - Directeur V%26B - CC.profile
src/profile/PostNL - IT Servicedesk - CC.profile
src/profile/PostNL - K%26K behandelaar.profile
src/profile/PostNL - Klachten Behandelaar - CC.profile
src/profile/PostNL - Klachten Inzage - CC.profile
src/profile/PostNL - Netwerk Behandelaar.profile
src/profile/PostNL - OBSB - CC.profile
src/profile/PostNL - OBSB Beheerder - CC.profile
src/profile/PostNL - OR Administrator - CC.profile
src/profile/PostNL - Postbezorger Community - CC.profile
src/profile/PostNL - Postbezorger Community Chatter - CC.profile
src/profile/PostNL - Postbezorger Community Chauffeur - CC.profile
src/profile/PostNL - Postbezorger Community Extern - CC.profile
src/profile/PostNL - Postbezorger Community PB ZW - CC.profile
src/profile/PostNL - Postbezorger Community Voorbereiden - CC.profile
src/profile/PostNL - Procesmanager Bezorgen - CC.profile
src/profile/PostNL - Procesmanager Voorbereiden - CC.profile
src/profile/PostNL - Regiomanagers - CC.profile
src/profile/PostNL - Service Centrum Medewerker.profile
src/profile/PostNL - Teamleider - CC.profile
src/profile/PostNL - Teamleider Voorbereiden - CC.profile
src/profile/PostNL - Werkorder behandelaar - CC.profile
src/profile/ReadOnly.profile
src/profile/SolutionManager.profile
src/profile/Standard.profile';
my $regex = qr/(?<=\/)[^\/]*(?=\.)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}