#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\/)[^\/]*(?=\.)"
Local $sString = "src/profile/Admin.profile" & @CRLF & _
"src/profile/Chatter External User.profile" & @CRLF & _
"src/profile/Chatter Free User.profile" & @CRLF & _
"src/profile/Chatter Moderator User.profile" & @CRLF & _
"src/profile/Company Communities User.profile" & @CRLF & _
"src/profile/ContractManager.profile" & @CRLF & _
"src/profile/Guest License User.profile" & @CRLF & _
"src/profile/High Volume Customer Portal User.profile" & @CRLF & _
"src/profile/Integratie.profile" & @CRLF & _
"src/profile/MarketingProfile.profile" & @CRLF & _
"src/profile/OWS.profile" & @CRLF & _
"src/profile/Photos Profile.profile" & @CRLF & _
"src/profile/PostNL - Audit.profile" & @CRLF & _
"src/profile/PostNL - Business gebruiker.profile" & @CRLF & _
"src/profile/PostNL - Controlroom C%26S Aanmaker - CC.profile" & @CRLF & _
"src/profile/PostNL - Controlroom C%26S Analist - CC.profile" & @CRLF & _
"src/profile/PostNL - Controlroom C%26S Behandelaar - CC.profile" & @CRLF & _
"src/profile/PostNL - DUB - CC.profile" & @CRLF & _
"src/profile/PostNL - Directeur V%26B - CC.profile" & @CRLF & _
"src/profile/PostNL - IT Servicedesk - CC.profile" & @CRLF & _
"src/profile/PostNL - K%26K behandelaar.profile" & @CRLF & _
"src/profile/PostNL - Klachten Behandelaar - CC.profile" & @CRLF & _
"src/profile/PostNL - Klachten Inzage - CC.profile" & @CRLF & _
"src/profile/PostNL - Netwerk Behandelaar.profile" & @CRLF & _
"src/profile/PostNL - OBSB - CC.profile" & @CRLF & _
"src/profile/PostNL - OBSB Beheerder - CC.profile" & @CRLF & _
"src/profile/PostNL - OR Administrator - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community Chatter - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community Chauffeur - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community Extern - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community PB ZW - CC.profile" & @CRLF & _
"src/profile/PostNL - Postbezorger Community Voorbereiden - CC.profile" & @CRLF & _
"src/profile/PostNL - Procesmanager Bezorgen - CC.profile" & @CRLF & _
"src/profile/PostNL - Procesmanager Voorbereiden - CC.profile" & @CRLF & _
"src/profile/PostNL - Regiomanagers - CC.profile" & @CRLF & _
"src/profile/PostNL - Service Centrum Medewerker.profile" & @CRLF & _
"src/profile/PostNL - Teamleider - CC.profile" & @CRLF & _
"src/profile/PostNL - Teamleider Voorbereiden - CC.profile" & @CRLF & _
"src/profile/PostNL - Werkorder behandelaar - CC.profile" & @CRLF & _
"src/profile/ReadOnly.profile" & @CRLF & _
"src/profile/SolutionManager.profile" & @CRLF & _
"src/profile/Standard.profile"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")