re = /202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]/m
str = '2020-11-09_15:36:38
2020-12-29_15:36:38
2029-09-09_15:36:38
2020-11-31_15:36:38
2020-11-31_00:00:00
2020-11-31_23:59:59
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end