const regex = /202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]', 'gm')
const str = `2020-11-09_15:36:38
2020-12-29_15:36:38
2029-09-09_15:36:38
2020-11-31_15:36:38
2020-11-31_00:00:00
2020-11-31_23:59:59
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}