#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*Processo\s*\d{7}\-\d{2}\.\d{4}\.\d\.\d{2}\.\d{4}\,"
Local $sString = "PROCESSO :1000069-51.2019.8.26.0486" & @CRLF & _
"Processo 0000508-21.2015.8.26.0486" & @CRLF & _
"Processo 0010464-93.2018.8.26.0506/02" & @CRLF & _
"Processo 0022276-35.2018.8.26.0506/562" & @CRLF & _
"Nº 0000002-25.2019.8.26.9048" & @CRLF & _
"540.423 -" & @CRLF & _
"1.125.553 -" & @CRLF & _
"NPE 950.128" & @CRLF & _
"PEC 910.494 " & @CRLF & _
"NPE 1.177.941" & @CRLF & _
"EXPEDIENTE AVULSO - NPE 1.089.733" & @CRLF & _
"EXECUÇÃO: 699.764" & @CRLF & _
"EXECUÇÃO: 1.101.909" & @CRLF & _
"CPPJ 12/2013 E 64/2013 " & @CRLF & _
"1. EXECUÇÃO Nº 629.142" & @CRLF & _
"2. EXECUÇÃO Nº 1.013.657" & @CRLF & _
"PROTOCOLO Nº 543 FSBL 1800017858-9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")