# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(餐盘|餐具|餐盒)收(一下|下|掉)?|收(一下|下)?(餐盘|餐具|餐盒|餐)"
test_str = ("收一下餐。\n"
"吗,我总是吗个服务员帮我收下餐盘。\n"
"收一下餐。\n"
"收餐?\n"
"帮我叫个服务员收一下餐盘。\n"
"嗯,收一下餐具。\n"
"收一下餐。\n"
"就是麻烦你收费早餐算呢?\n"
"收一下餐。\n"
"帮我收一下餐盘。\n"
"帮我收一下餐盘。\n"
"嗯,帮我收回去好吗?我这个用餐有用完了。\n"
"收餐?\n"
"请帮我收一下餐盘。\n\n"
"收一下餐。\n"
"吗,我总是吗个服务员帮我收下餐盘。\n"
"收一下餐。\n"
"我刚刚有一份那个中餐收到了,没有?\n"
"早餐九点半收。\n"
"收餐?\n"
"帮我叫个服务员收一下餐盘。\n"
"嗯,收一下餐具。\n"
"收一下餐。\n"
"就是麻烦你收费早餐算呢?\n"
"收一下餐。\n"
"帮我收一下餐盘。\n"
"帮我收一下餐盘。\n"
"早餐收钱吗?\n"
"嗯,帮我收回去好吗?我这个用餐有用完了。\n"
"把那个餐具收掉。\n"
"帮我把餐盒拿收拾下房间。\n"
"收餐?\n"
"请帮我收一下餐盘。")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.