$re = '/(餐盘|餐具|餐盒)收(一下|下|掉)?|收(一下|下)?(餐盘|餐具|餐盒|餐)/m';
$str = '收一下餐。
吗,我总是吗个服务员帮我收下餐盘。
收一下餐。
收餐?
帮我叫个服务员收一下餐盘。
嗯,收一下餐具。
收一下餐。
就是麻烦你收费早餐算呢?
收一下餐。
帮我收一下餐盘。
帮我收一下餐盘。
嗯,帮我收回去好吗?我这个用餐有用完了。
收餐?
请帮我收一下餐盘。
收一下餐。
吗,我总是吗个服务员帮我收下餐盘。
收一下餐。
我刚刚有一份那个中餐收到了,没有?
早餐九点半收。
收餐?
帮我叫个服务员收一下餐盘。
嗯,收一下餐具。
收一下餐。
就是麻烦你收费早餐算呢?
收一下餐。
帮我收一下餐盘。
帮我收一下餐盘。
早餐收钱吗?
嗯,帮我收回去好吗?我这个用餐有用完了。
把那个餐具收掉。
帮我把餐盒拿收拾下房间。
收餐?
请帮我收一下餐盘。';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);