package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[6-9]{1}[0-9]{9}$`)
var str = `8082011232`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}