import Foundation
let pattern = #"COPD\sGOLD\s([0-9])([A-Z])?\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Infektexacerbierte COPD GOLD 2
COPD GOLD 2
COPD GOLD 3B
Betablocker wurden bei COPD GOLD 4 nicht verabreicht.
COPD Stadium D nach GOLD mit Emphysem
Risikogruppe B nach GOLD mit \rrespiratorischer Globalinsuffizi
Virale infektexazerbierte COPD GOLD D
Exazerbierte COPD mit erforderlicher intermittierender BiPAP-Beatmung bei hyperkapnischen respiratorischen Insuffizienz\rLungenemphysem, COPD Stadium GOLD 4\
Risikoklasse D nach GOLD mit respiratorischer Partialinsuffizienz in Ruhe
m II-III, Risikogruppe D nach GOLD
COPD Stad. II nach GOLD$
rt. Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte
Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi
m II-III, Risikogruppe D nach GOLD
COPD Stad. II nach GOLD
Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte
Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi
OPD bekannt Grad 1 bis 2 nach GOLD , antiobstruktive Therapie mi
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)