import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "COPD\\sGOLD\\s([0-9])([A-Z])?\\b";
final String string = "Infektexacerbierte COPD GOLD 2\n"
+ "COPD GOLD 2\n"
+ "COPD GOLD 3B\n"
+ "Betablocker wurden bei COPD GOLD 4 nicht verabreicht.\n\n"
+ "COPD Stadium D nach GOLD mit Emphysem\n"
+ "Risikogruppe B nach GOLD mit \\rrespiratorischer Globalinsuffizi\n"
+ "Virale infektexazerbierte COPD GOLD D\n"
+ "Exazerbierte COPD mit erforderlicher intermittierender BiPAP-Beatmung bei hyperkapnischen respiratorischen Insuffizienz\\rLungenemphysem, COPD Stadium GOLD 4\\\n"
+ "Risikoklasse D nach GOLD mit respiratorischer Partialinsuffizienz in Ruhe\n"
+ "m II-III, Risikogruppe D nach GOLD\n"
+ "COPD Stad. II nach GOLD$\n"
+ "rt. Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte\n"
+ "Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi\n"
+ "m II-III, Risikogruppe D nach GOLD\n"
+ "COPD Stad. II nach GOLD\n"
+ "Bei bek. COPD St. IV nach GOLD stellte sich ein prolongierte\n"
+ "Beurteilung: COPD III nach GOLD Lungenemphysem. Keine asthmoi\n"
+ "OPD bekannt Grad 1 bis 2 nach GOLD , antiobstruktive Therapie mi";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}