# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([0-9]{4}\.[0-9]{2}\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\] \[([a-zA-Z]+)\] \[(.+)\] \[(.+)\] (.*)"
test_str = ("[2019.01.10 22:45:37] [INFO] [main] [Config] Starting to load configuration!\n"
"[2019.01.10 22:45:38] [WARN] [main] [Config] Value for key: shard_num was not provided! Using default value: \"-1\"\n"
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: default_prefix was not provided! Using default value: \";\"\n"
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.server was not provided! Using default value: \"https://hastebin.com/documents\"\n"
"[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.link was not provided! Using default value: \"https://hastebin.com/\"\n"
"[2019.01.10 22:45:39] [INFO] [main] [Config] Finished loading configuration!\n"
"[2019.01.10 22:45:43] [INFO] [main] [ShardManager] Login Successful!\n"
"[2019.01.10 22:45:43] [INFO] [main] [Command Manager] Loaded 7 commands in 85ms.\n"
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-WriteThread] [WebSocketClient] Connected to WebSocket\n"
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [JDA] Finished Loading!\n"
"[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [CascadeBot] All shards successfully logged in!")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.