use strict;
my $str = '[2019.01.10 22:45:37] [INFO] [main] [Config] Starting to load configuration!
[2019.01.10 22:45:38] [WARN] [main] [Config] Value for key: shard_num was not provided! Using default value: "-1"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: default_prefix was not provided! Using default value: ";"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.server was not provided! Using default value: "https://hastebin.com/documents"
[2019.01.10 22:45:39] [WARN] [main] [Config] Value for key: haste.link was not provided! Using default value: "https://hastebin.com/"
[2019.01.10 22:45:39] [INFO] [main] [Config] Finished loading configuration!
[2019.01.10 22:45:43] [INFO] [main] [ShardManager] Login Successful!
[2019.01.10 22:45:43] [INFO] [main] [Command Manager] Loaded 7 commands in 85ms.
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-WriteThread] [WebSocketClient] Connected to WebSocket
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [JDA] Finished Loading!
[2019.01.10 22:45:43] [INFO] [JDA [0 / 1] MainWS-ReadThread] [CascadeBot] All shards successfully logged in!';
my $regex = qr/\[([0-9]{4}\.[0-9]{2}\.[0-9]{2} [0-9]{2}:[0-9]{2}:[0-9]{2})\] \[([a-zA-Z]+)\] \[(.+)\] \[(.+)\] (.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}