// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<name>.*)time:\s*\[(?<low>\d+\.?\d*)\s(?:\w{1,2})\s(?<value>\d+\.?\d*)\s(?<unit>\w{1,2})\s(?<high>\d+\.?\d*).*$").unwrap();
let string = "Symbol Creation time: [567.19 us 572.98 us 580.80 us]
Found 17 outliers among 100 measurements (17.00%)
4 (4.00%) high mild
13 (13.00%) high severe
Running target/release/deps/fib-9ff430dbccaab995
Benchmarking fibonacci (Execution): Warming up for 3.0000 s
fibonacci (Execution) time: [5.4756 ms 5.5354 ms 5.6049 ms]
Found 13 outliers among 100 measurements (13.00%)
3 (3.00%) high mild
10 (10.00%) high severe
Running target/release/deps/string-21e60149b4b73866
Hello World (Execution) time: [518.17 us 519.92 us 521.89 us]
Found 12 outliers among 100 measurements (12.00%)
7 (7.00%) high mild
5 (5.00%) high severe
Hello World (Lexer) time: [1.8861 us 1.9440 us 2.0071 us]
change: [+13.420% +15.685% +17.802%] (p = 0.00 < 0.05)
Performance has regressed.
Found 2 outliers among 100 measurements (2.00%)
1 (1.00%) high mild
1 (1.00%) high severe
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}