#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<name>.*)time:\s*\[(?<low>\d+\.?\d*)\s(?:\w{1,2})\s(?<value>\d+\.?\d*)\s(?<unit>\w{1,2})\s(?<high>\d+\.?\d*).*$"
Local $sString = "Symbol Creation time: [567.19 us 572.98 us 580.80 us]" & @CRLF & _
"Found 17 outliers among 100 measurements (17.00%)" & @CRLF & _
" 4 (4.00%) high mild" & @CRLF & _
" 13 (13.00%) high severe" & @CRLF & _
"" & @CRLF & _
" Running target/release/deps/fib-9ff430dbccaab995" & @CRLF & _
"Benchmarking fibonacci (Execution): Warming up for 3.0000 s" & @CRLF & _
"fibonacci (Execution) time: [5.4756 ms 5.5354 ms 5.6049 ms]" & @CRLF & _
"Found 13 outliers among 100 measurements (13.00%)" & @CRLF & _
" 3 (3.00%) high mild" & @CRLF & _
" 10 (10.00%) high severe" & @CRLF & _
"" & @CRLF & _
" Running target/release/deps/string-21e60149b4b73866" & @CRLF & _
"Hello World (Execution) time: [518.17 us 519.92 us 521.89 us]" & @CRLF & _
"Found 12 outliers among 100 measurements (12.00%)" & @CRLF & _
" 7 (7.00%) high mild" & @CRLF & _
" 5 (5.00%) high severe" & @CRLF & _
" " & @CRLF & _
"Hello World (Lexer) time: [1.8861 us 1.9440 us 2.0071 us]" & @CRLF & _
" change: [+13.420% +15.685% +17.802%] (p = 0.00 < 0.05)" & @CRLF & _
" Performance has regressed." & @CRLF & _
"Found 2 outliers among 100 measurements (2.00%)" & @CRLF & _
" 1 (1.00%) high mild" & @CRLF & _
" 1 (1.00%) high severe" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")