# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:https?|ftp|file):\/\/|www\.|ftp\.)(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[-A-Z0-9+&@#\/%=~_|$?!:,.])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$])"
test_str = ("08/27/2018 08:55:31 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/lekhaigiang.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_85.prproj\n"
" - Output File: C:\\000\\thebhyt.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:31:19\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:21\n"
"08/27/2018 08:55:48 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:55:51 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thebhyt.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_86.prproj\n"
" - Output File: C:\\000\\vhdangian.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:02:55:14\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:01:41\n"
"08/27/2018 08:57:31 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:57:50 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/vhdangian.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_87.prproj\n"
" - Output File: C:\\000\\caotocbacnam.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:01:04:22\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:37\n"
"08/27/2018 08:58:09 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:58:19 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/caotocbacnam.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_88.prproj\n"
" - Output File: C:\\000\\thatdayantoan.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:36:01\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:21\n"
"08/27/2018 08:58:31 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:58:53 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thatdayantoan.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_89.prproj\n"
" - Output File: C:\\000\\xulyvipham.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:49:10\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:28\n"
"08/27/2018 08:59:21 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:59:41 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/xulyvipham.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_90.prproj\n"
" - Output File: C:\\000\\hoahoankhonemmut.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:41:23\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:25\n"
"08/27/2018 08:59:50 AM : File Successfully Encoded\n\n\n"
"08/27/2018 08:59:54 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/hoahoankhonemmut.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_91.prproj\n"
" - Output File: C:\\000\\xedulichbocchay.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:31:15\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:24\n"
"08/27/2018 09:00:15 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:00:18 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/xedulichbocchay.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_92.prproj\n"
" - Output File: C:\\000\\thithe.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:35:20\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:22\n"
"08/27/2018 09:00:38 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:00:47 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thithe.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_93.prproj\n"
" - Output File: C:\\000\\cansa.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:43:19\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:24\n"
"08/27/2018 09:01:11 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:01:22 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/cansa.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_94.prproj\n"
" - Output File: C:\\000\\ngoaihanhtinh.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:39:11\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:21\n"
"08/27/2018 09:01:44 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:01:48 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/ngoaihanhtinh.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_95.prproj\n"
" - Output File: C:\\000\\tainghechongon.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:29:14\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:20\n"
"08/27/2018 09:02:05 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:02:19 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/tainghechongon.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_96.prproj\n"
" - Output File: C:\\000\\quantam.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:43:04\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:28\n"
"08/27/2018 09:02:34 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:02:34 AM : Queue Stopped\n\n\n"
"08/27/2018 09:02:38 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/quantam.mp4\n\n\n"
"08/27/2018 09:02:38 AM : Queue Stopped\n\n\n"
"08/27/2018 09:32:13 AM : Queue Started\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_97.prproj\n"
" - Output File: C:\\000\\huyenuyphongdien.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:58:22\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:21\n"
"08/27/2018 09:32:34 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:32:34 AM : Queue Stopped\n\n\n"
"08/27/2018 09:32:38 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/huyenuyphongdien.mp4\n\n\n"
"08/27/2018 09:32:38 AM : Queue Stopped\n\n\n"
"08/27/2018 09:38:51 AM : Queue Started\n\n\n"
"08/27/2018 09:39:04 AM : Queue Paused\n\n\n"
"08/27/2018 09:39:08 AM : Queue Started\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_98.prproj\n"
" - Output File: C:\\000\\xavinhtrinh.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:42:20\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:29\n"
"08/27/2018 09:39:21 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:39:22 AM : Queue Paused\n\n\n"
"08/27/2018 09:39:27 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/xavinhtrinh.mp4\n\n\n"
"08/27/2018 09:39:27 AM : Queue Stopped\n\n\n"
"08/27/2018 09:39:37 AM : Queue Started\n\n\n"
"08/27/2018 09:39:47 AM : Queue Paused\n\n\n"
"08/27/2018 09:39:51 AM : Queue Started\n\n\n"
"08/27/2018 09:39:55 AM : Queue Paused\n\n\n"
"08/27/2018 09:39:58 AM : Queue Started\n\n\n"
"08/27/2018 09:40:03 AM : Queue Paused\n\n\n"
"08/27/2018 09:40:13 AM : Queue Started\n\n\n"
"08/27/2018 09:40:17 AM : Queue Paused\n\n\n"
"08/27/2018 09:40:21 AM : Queue Started\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_299.prproj\n"
" - Output File: C:\\000\\vinhthanh.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:56:02\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:51\n"
"08/27/2018 09:40:29 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:40:33 AM : Queue Paused\n\n\n"
"08/27/2018 09:40:34 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/vinhthanh.mp4\n\n\n"
"08/27/2018 09:40:35 AM : Queue Started\n\n\n"
"08/27/2018 09:40:37 AM : Queue Paused\n\n\n"
"08/27/2018 09:40:38 AM : Queue Started\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_300.prproj\n"
" - Output File: C:\\000\\doithoaibhyt.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:37:21\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:27\n"
"08/27/2018 09:40:56 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:41:25 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/doithoaibhyt.mp4\n\n\n"
"08/27/2018 09:41:25 AM : Queue Paused\n\n\n"
"08/27/2018 09:42:25 AM : Queue Started\n\n\n"
"08/27/2018 09:42:26 AM : Queue Paused\n\n\n"
"08/27/2018 09:42:28 AM : Queue Started\n\n\n"
"08/27/2018 09:42:28 AM : Queue Paused\n\n\n"
"08/27/2018 09:42:29 AM : Queue Started\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_301.prproj\n"
" - Output File: C:\\000\\giaothongthuy.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:47:00\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:28\n"
"08/27/2018 09:42:54 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:43:01 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/giaothongthuy.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_302.prproj\n"
" - Output File: C:\\000\\nhonnghia.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:47:00\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:32\n"
"08/27/2018 09:43:32 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:43:43 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/nhonnghia.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_303.prproj\n"
" - Output File: C:\\000\\ctdthotnot.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:35:05\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:17\n"
"08/27/2018 09:44:00 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:44:20 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/ctdthotnot.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_304.prproj\n"
" - Output File: C:\\000\\cfdongvat.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:48:01\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:18\n"
"08/27/2018 09:44:39 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:44:57 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/cfdongvat.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_305.prproj\n"
" - Output File: C:\\000\\cumheo.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:23:00\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:14\n"
"08/27/2018 09:45:12 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:45:21 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/cumheo.mp4\n\n\n"
" - Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_306.prproj\n"
" - Output File: C:\\000\\trienlam5g.mp4\n"
" - Preset Used: canthotv\n"
" - Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:49:03\n"
" - Audio: AAC, 112 kbps, 48 kHz, Stereo\n"
" - Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps\n"
" - Encoding Time: 00:00:32\n"
"08/27/2018 09:45:44 AM : File Successfully Encoded\n\n\n"
"08/27/2018 09:45:44 AM : Queue Stopped\n\n\n"
"08/27/2018 09:45:50 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/trienlam5g.mp4\n\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.