$re = '/(?:(?:https?|ftp|file):\/\/|www\.|ftp\.)(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[-A-Z0-9+&@#\/%=~_|$?!:,.])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$])/i';
$str = '08/27/2018 08:55:31 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/lekhaigiang.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_85.prproj
- Output File: C:\\000\\thebhyt.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:31:19
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:21
08/27/2018 08:55:48 AM : File Successfully Encoded
08/27/2018 08:55:51 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thebhyt.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_86.prproj
- Output File: C:\\000\\vhdangian.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:02:55:14
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:01:41
08/27/2018 08:57:31 AM : File Successfully Encoded
08/27/2018 08:57:50 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/vhdangian.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_87.prproj
- Output File: C:\\000\\caotocbacnam.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:01:04:22
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:37
08/27/2018 08:58:09 AM : File Successfully Encoded
08/27/2018 08:58:19 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/caotocbacnam.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_88.prproj
- Output File: C:\\000\\thatdayantoan.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:36:01
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:21
08/27/2018 08:58:31 AM : File Successfully Encoded
08/27/2018 08:58:53 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thatdayantoan.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_89.prproj
- Output File: C:\\000\\xulyvipham.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:49:10
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:28
08/27/2018 08:59:21 AM : File Successfully Encoded
08/27/2018 08:59:41 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/xulyvipham.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_90.prproj
- Output File: C:\\000\\hoahoankhonemmut.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:41:23
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:25
08/27/2018 08:59:50 AM : File Successfully Encoded
08/27/2018 08:59:54 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/hoahoankhonemmut.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_91.prproj
- Output File: C:\\000\\xedulichbocchay.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:31:15
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:24
08/27/2018 09:00:15 AM : File Successfully Encoded
08/27/2018 09:00:18 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/xedulichbocchay.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_92.prproj
- Output File: C:\\000\\thithe.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:35:20
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:22
08/27/2018 09:00:38 AM : File Successfully Encoded
08/27/2018 09:00:47 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/thithe.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_93.prproj
- Output File: C:\\000\\cansa.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:43:19
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:24
08/27/2018 09:01:11 AM : File Successfully Encoded
08/27/2018 09:01:22 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/cansa.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_94.prproj
- Output File: C:\\000\\ngoaihanhtinh.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:39:11
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:21
08/27/2018 09:01:44 AM : File Successfully Encoded
08/27/2018 09:01:48 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/ngoaihanhtinh.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_95.prproj
- Output File: C:\\000\\tainghechongon.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:29:14
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:20
08/27/2018 09:02:05 AM : File Successfully Encoded
08/27/2018 09:02:19 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/tainghechongon.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_96.prproj
- Output File: C:\\000\\quantam.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:43:04
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:28
08/27/2018 09:02:34 AM : File Successfully Encoded
08/27/2018 09:02:34 AM : Queue Stopped
08/27/2018 09:02:38 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/27/quantam.mp4
08/27/2018 09:02:38 AM : Queue Stopped
08/27/2018 09:32:13 AM : Queue Started
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_97.prproj
- Output File: C:\\000\\huyenuyphongdien.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:58:22
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:21
08/27/2018 09:32:34 AM : File Successfully Encoded
08/27/2018 09:32:34 AM : Queue Stopped
08/27/2018 09:32:38 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/huyenuyphongdien.mp4
08/27/2018 09:32:38 AM : Queue Stopped
08/27/2018 09:38:51 AM : Queue Started
08/27/2018 09:39:04 AM : Queue Paused
08/27/2018 09:39:08 AM : Queue Started
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_98.prproj
- Output File: C:\\000\\xavinhtrinh.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:42:20
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:29
08/27/2018 09:39:21 AM : File Successfully Encoded
08/27/2018 09:39:22 AM : Queue Paused
08/27/2018 09:39:27 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/xavinhtrinh.mp4
08/27/2018 09:39:27 AM : Queue Stopped
08/27/2018 09:39:37 AM : Queue Started
08/27/2018 09:39:47 AM : Queue Paused
08/27/2018 09:39:51 AM : Queue Started
08/27/2018 09:39:55 AM : Queue Paused
08/27/2018 09:39:58 AM : Queue Started
08/27/2018 09:40:03 AM : Queue Paused
08/27/2018 09:40:13 AM : Queue Started
08/27/2018 09:40:17 AM : Queue Paused
08/27/2018 09:40:21 AM : Queue Started
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_299.prproj
- Output File: C:\\000\\vinhthanh.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:56:02
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:51
08/27/2018 09:40:29 AM : File Successfully Encoded
08/27/2018 09:40:33 AM : Queue Paused
08/27/2018 09:40:34 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/vinhthanh.mp4
08/27/2018 09:40:35 AM : Queue Started
08/27/2018 09:40:37 AM : Queue Paused
08/27/2018 09:40:38 AM : Queue Started
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_300.prproj
- Output File: C:\\000\\doithoaibhyt.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:37:21
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:27
08/27/2018 09:40:56 AM : File Successfully Encoded
08/27/2018 09:41:25 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/doithoaibhyt.mp4
08/27/2018 09:41:25 AM : Queue Paused
08/27/2018 09:42:25 AM : Queue Started
08/27/2018 09:42:26 AM : Queue Paused
08/27/2018 09:42:28 AM : Queue Started
08/27/2018 09:42:28 AM : Queue Paused
08/27/2018 09:42:29 AM : Queue Started
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_301.prproj
- Output File: C:\\000\\giaothongthuy.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:47:00
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:28
08/27/2018 09:42:54 AM : File Successfully Encoded
08/27/2018 09:43:01 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/giaothongthuy.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_302.prproj
- Output File: C:\\000\\nhonnghia.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:47:00
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:32
08/27/2018 09:43:32 AM : File Successfully Encoded
08/27/2018 09:43:43 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/nhonnghia.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_303.prproj
- Output File: C:\\000\\ctdthotnot.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:35:05
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:17
08/27/2018 09:44:00 AM : File Successfully Encoded
08/27/2018 09:44:20 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/ctdthotnot.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_304.prproj
- Output File: C:\\000\\cfdongvat.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:48:01
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:18
08/27/2018 09:44:39 AM : File Successfully Encoded
08/27/2018 09:44:57 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/cfdongvat.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_305.prproj
- Output File: C:\\000\\cumheo.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:23:00
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:14
08/27/2018 09:45:12 AM : File Successfully Encoded
08/27/2018 09:45:21 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/cumheo.mp4
- Source File: C:\\Users\\tdngan\\AppData\\Local\\Temp\\work_306.prproj
- Output File: C:\\000\\trienlam5g.mp4
- Preset Used: canthotv
- Video: 1024x576 (1,0), 25 fps, Progressive, Software Encoding, 00:00:49:03
- Audio: AAC, 112 kbps, 48 kHz, Stereo
- Bitrate: VBR, 2 pass, Target 1,00 Mbps, Max 1,50 Mbps
- Encoding Time: 00:00:32
08/27/2018 09:45:44 AM : File Successfully Encoded
08/27/2018 09:45:44 AM : Queue Stopped
08/27/2018 09:45:50 AM : FTP - ftp://media3.canthotv.vn/ngan/2018/TH/08/26/trienlam5g.mp4
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;